New Feature

  • Autotask integration has been introduced in this release.

Improvements

  • Notification messages are updated to new design throughout the application.
  • Date and Expiry Date Fields were not aligned properly. Improvement has been done now both fields are arranged next to each other.
  • Password page fields were not aligned. Improvement has been done now the fields are aligned.
  • Connectwise Automate integration validations UI changes are made.
  • Company favorite widget loader was not in its proper place. UI has been fixed.
  • The notification text was not centralized while syncing. This has been done.

Fixes

  • There was an issue with screenconnect. It was showing unknown machines as well with client’s machine. This issue has been fixed now.
  • Internal user having Editor Role was Unable to Access Feedback. This issue has been fixed now.
  • Previously the asset warranty date was sorted by the first digit appearing in date, rather than on year basis. This issue has been fixed now the date is sorted on year basis.
  • There was an issue with knowledge base deletion. After deletion it was still showing in the search. This issue has been fixed now.
  • There was an issue with ITboost top navigation bar on mobile view. This issue has been fixed now.
  • The text was disappearing on editing the document in knowledgebase. This issue has been fixed now.
  • There was an issue in contact dashboard widgets, link item were not populating the widgets. This issue has been fixed now.
  • On editing the passwords from the profile, the view was getting disturbed. This issue has been fixed now.
  • There was a problem in BI custom widget. Filtering of data through days were not working fine. This issue has been fixed now.
  • The custom templates linked fields was defaulting to the last entry. This issue has been fixed now.
  • The questions in custom feedback with Radio button was not appearing in results. This issue has been fixed now.
  • There was an issue in validating ConnectWise control. This issue has been fixed now.
  • In Kb’s tree view there was orphaned tree objects appearing in some scenarios. This issue has been fixed now.
  • There was an issue in importing global Kb’s those have special characters in their name. This has been handled.
  • There was a tool tip issue in custom template. This issue has been fixed now.
  • On adding configurations, status field values were showing twice. This issue has been fixed now.
  • SC password field was auto filled in user edit form. This issue has been fixed now.
  • Contact page appearing broken when we add contact from company add page. This issue has been fixed now.
  • There was an issue with knowledge base loader appearing on recycle bin button. This issue has been fixed now.
Did this answer your question?